WordPress Updates – Protect Your Blog From Being Hacked

I was browsing the internet and saw something that got my attention. It will grab yours too, trust me. I’m talking about WordPress security and vulnerabilities here, and there’s much to say about it, so I’ve started a new category where to post.

The very first and most important thing you need to do to help your blog stay safe all the time is to keep it updated to the latest version. That’s the most safe (at least that’s what they say). Every time a new bug/security hole is found, the platform gets updated with a fix and then the bug is published. In short words, everybody knows about it.

If you don’t want to mess with ftp and downloads and so on, you might want to use a plugin that does your updating automatically. This way you’ll always have your WordPress blog up to date. I don’t remember the name of that plugin because I don’t use it, but if you wish to install it, do a simply search on Google or on wordpress.com site and you’ll find it pretty fast. I don’t use it because I don’t like having too much “foreign” code on my server… you never know what can happen to your database or whatever. Therefore, I prefer to update it manually.

Oh … and by the way, I was talking about plugins. When you get a new plugin, make sure it’s a safe one. Don’t install any plugin just because the owner is saying on his website that plugin will help you do this or that. Maybe use a test blog to check the plugin, or maybe get a software engineer to analyze it carefully. This way you’ll know it isn’t a threat for you or your business.



Source by Peter Jacob

2019-03-17T23:50:53+00:00

Leave A Comment

This website uses cookies and third party services. Accept